strict warning: Non-static method

Hello,
I recently installed Fragile, thank you for providing it to the community. I am getting a number of "strict warning: Non-static method" warnings. I am using PHP 5.4. Is this perhaps the culprit?

If my PHP version is the issue, I found some posts (https://groups.drupal.org/node/217529#comment-903913) for how to turn off the string warnings.

The ones I get when I choose the menu item "Clients" are listed below but I get them on a number of pages.

    strict warning: Non-static method view::load() should not be called statically in .../fragile/profiles/fragile/modules/contrib/views/views.module on line 879.
    strict warning: Declaration of views_handler_filter::options_validate() should be compatible with views_handler::options_validate($form, &$form_state) in .../fragile/profiles/fragile/modules/contrib/views/handlers/views_handler_filter.inc on line 589.
    strict warning: Declaration of views_handler_filter::options_submit() should be compatible with views_handler::options_submit($form, &$form_state) in .../fragile/profiles/fragile/modules/contrib/views/handlers/views_handler_filter.inc on line 589.
    strict warning: Declaration of views_handler_filter_boolean_operator::value_validate() should be compatible with views_handler_filter::value_validate($form, &$form_state) in .../fragile/profiles/fragile/modules/contrib/views/handlers/views_handler_filter_boolean_operator.inc on line 149.

I hope this is helpful to you.

Comments

Those warnings are probably OK

As long as the page is loading, then it's probably all working. Those kind of warnings in PHP are a sign that things aren't exactly how PHP expects them to be, but if the software is otherwise working as expected, then you can probably safely ignore the warnings.

--Julian